Contents

  1. Introduction
  2. Installation & Quick Start
  3. Menus
  4. SiteManager
  5. Editor Options
  6. Options

1. Introduction

FTPEditor combines an FTP client and a multi-document editor. So you can edit FTP files as if they were on your local hard drive. FTPEditor allows you to open these files directly from your FTP server, edit them and save the changed files again.

You can open multiple text files from different directories. FTPEditor will always save them into their correct place.

FTPEditor supports drag & drop in a various ways. You can drag text files from the file list and drop them into the edit to load them. It is also possible to move files to other directories by selecting them and dragging them to another entry in the file list.

FTPEditor includes all actions to manage files on a FTP site like upload, download, rename, delete, move. Directories can be created and removed.

2. Installation & Quick Start

2.1 System Requirements

Any PC running Windows 2000/XP/Vista/7.

2.2 Installation

Once you have downloaded FTPEditor, double click on the executable to run the setup and follow the directions on the screen. FTPEditor will be installed on your harddrive and by default setup will create a shortcut in your Programs folder.

2.3 Quick Start

Start FTPEditor from the Programs folder in the Windows Start menu. Now you can start editing files on an FTP server. Enter the name of the FTP server, user name and password in the corresponding field and press the “Connect” button.

FTPEditor will connect to the FTP server and display the servers directory structure on the left part of the screen. To open a file just double-click on it and it will be loaded into the editor, where you can start editing.

When you are done editing save the file using menu File|Save or File|Save As.

[ back to the top ]

3. Menus

FTPEditor has the following menus:

File Menu

File|New (Ctrl-N) – Using this command to open a new file.

File|Open (Ctrl-O) – This command loads the selected files from the file list into the editor. If the file is already opened you will be asked, if you want to open another copy of this file. You can also open selected files by drag & drop them into the editor.

NOTE:
Binary files cannot be edited within the editor. In the Tools|Options dialog you can specify which file extensions should not be opened.

File|Save (Ctrl-S) – Use this command to save the active document to its current name and its directory.
If you want to change the name and directory of an existing document before you save it, choose the “Save As”-command.

NOTE:
The directory, in which the document is stored in on the FTP server may be different from the current selected one. The home directory of the active document is displayed in the statusbar. This allows to have documents from multiple, different directories opened at the same time.

File|Save As (F12) – Use this command to save and name the active document. A “Save As” dialog box will appear so you can name your document.

File|Save All (Ctrl+Alt+S) – Use this command to save and name the active document. A “Save As” dialog box will appear so you can name your document.

File|Close (Ctrl+W) – Use this command to close the active document. FTPEditor prompts you to save if the documents contains unsaved changes.

File|Close All (Ctrl+Alt+W) – Use this command to close all open documents. FTPEditor prompts you to save if any document contains unsaved changes.

File|Download (Ctrl+D)– Use this command to download the selected files to your local hard drive. A “Save File” dialog will show up for each selected file, so it can be saved on the local drive.

File|Upload local file (Ctrl+U)– Use this command to upload a file from your hard drive to the current directory on the FTP server you are connected to. A “Open” dialog will appear so you can select the files you want to upload (multiple files can be selected).

File|Print (Ctrl+P) – Use this command to print a document. This command presents a Print dialog box, where you may specify the range of pages to be printed, the
number of copies, the destination printer, and other printer setup options.

File|Preview HTML – Use this command to preview a local copy of a HTML document. This command launches your standard web browser and loads the current file (this command is a only available when editing HTML documents).

File|Recently used files – Lists recently edited files. This can be local files or even remote files. With remoted files the server name is displayed with the file name – and FTPEditor connects to the server of the selected file automatically if it is not currently connected.

File|Exit – Use this command to end your FTPEditor session. You can also use the Close command on the application Control menu. FTPEditor prompts you to save documents with unsaved changes.

[ back to the top ]

Edit Menu

Edit|Undo (Ctrl+Z) – Use this command to reverse the last editing action, if possible. FTPEditor supports multiple levels of undo (the specific number varies based on the items being undone). Repeated Undo commands will attempt to step backwards through the previous commands and undo one at a time.

Edit|Redo (Ctrl+Shift+Z) – Use this command to reverse the last undo action, if possible.

Edit|Cut (Ctrl+X) – Use this command to remove the currently selected data from the document and put it on the clipboard. This command is unavailable if there is no text currently selected. Cutting data to the clipboard replaces the contents previously stored there.

Edit|Copy (Ctrl+C) – Use this command to copy selected data onto the clipboard. This command is unavailable if there is no text currently selected. Copying data to the clipboard replaces the contents previously stored there.

Edit|Paste (Ctrl+P) – Use this command to insert a copy of the clipboard contents at the insertion point. This command is unavailable if the clipboard is empty.

Edit|Delete (Ctrl+Del) – This command deletes the selected text. This command is unavailable if there is no text currently selected.

Edit|Find (Ctrl+F) – This command displays a dialog box for searching the document for the specified text. The search is performed in the direction specified. If the string is not found, the search wraps around to the other end of the file and continues the search. If the string is not found a message is displayed.

Edit|Search Again (F3) – This command searches for the occurrence of the last search string.

Edit|Replace (Ctrl+R) – This command displays a dialog box for replacing the specified text.

Edit|Go to Line Number (Ctrl+G) – This command displays a dialog box to enter a line number at which the cursor will be placed after pressing Ok.

Edit|Match Bracket (Shift+Ctrl+M) – When the cursor is located at a opening or closing bracket this command move the cursor to the counterpart of the bracket – if found.

NOTE:
The matching bracket is also highlighted by the editor, when the cursor is placed at it.

Edit | Syntax Highlighting – Lists the available syntax highlighting for various languages. Although FTPEditor detects the appropriate highlighter according to the file extension. The highlighter can be changed here.

Edit|Linebreaks – Use this to define the type of linebreaks you would like to have in the current editor.

Edit|Select All (Ctrl-A) – The select all command highlights the complete file. This allows an easy mechanism to select the complete file and Copy / Cut it into the clipboard.

[ back to the top ]

View Menu

View|Toolbars – Lists the available toolbar in a submenu and allows to show or hide them.

View|FTP Directory (F7) – This command displays/hides the FTP file list window. The FTP file window lists the files and subfolders in the current working directory of the FTP server. It is located to the left the text editor.

View|FTP Log (F8) – This command displays/hides the FTP log window. The FTP log window list the result states which are received from the FTP server you are currently connected to. It is located below the text editor.

View|Explorer (F9) – This command displays/hides the Local Explorer tab which can be used to manage local files.

View|Transfer Queue (F10) – This command displays/hides the FTP transfer queue, which displays the list of files which are queued to be transfered to/from the FTP server.

View|Browser – Display the inline browser tab. The browser tab is an embed Internet Explorer view.

[ back to the top ]

FTP Menu

FTP|Connect – Use this command to connect to a FTP server. You have to enter the FTP server in the host field and also enter user id and password if necessary.

FTP|Disconnect – Use this command to disconnect from a FTP server.

FTP|Abort – Use this command to abort a transfer. You may need this command if a transfer take very long and you want to stop it.

FTP|Delete – Use this command to delete the selected files/directories. You will be prompted to confirm the deletion.

NOTE:
If you delete a directory, all files and other directory within this folder will be deleted as well.

FTP|Move – Use this command to move the selected files/directories. You will be asked to enter the new destination.

FTP|Rename – Use this command to rename the selected file/directory. A “rename” dialog will be presented where you can enter a new name.

FTP|Change Directory – Use this command to change the current directory. You will be asked to enter the name of the directory you want to change to in a dialog box.

FTP|Make Directory – Use this command to create a new directory below the current directory (shown in the file list). You will be asked to enter the name of the new directory in a dialog box.

FTP|Bookmark Directory – Mark regularly used folders as bookmarks by using this command. Bookmarks will be stored in the SiteManager (see Bookmark tab). Bookmarks are loaded into the remote folder history when you connect. This make navigating into these folders fast & easy.

FTP|Transfer Mode – Use this command to set the FTP transfer mode. Set it to “Auto” if you want FTPEditor to decide which mode to use for a file. Or you may set the transfer mode to either ASCII or binary manually.

NOTE:
FTPEditor will use ASCII transfer for all files, except the ones which are declared as binary files in Tools|Options.

FTP|Add to SiteManager – Store a connection established by direct input of hostname, username and password for future usage into the SiteManager.

FTP|Properties (Alt-Enter) – Use this command to display advanced properties about the selected file or directory. You may also be able to change permissions for the file/directory (if supported by the FTP server).

[ back to the top ]

Tools Menu

Tools|Editor Properties – This command displays the editor properties dialog. See Editor Options for details.

Tools|SiteManager – This command displays the SiteManager window – see the chapter SiteManager for details.

Tools|Options – This command displays the FTPEditor Options dialog.

Tools|Convert Tabs to Spaces – Converts all tab characters of the current document into spaces. The amount of spaces used is taken from the Editor Options.

[ back to the top ]

Help Menu

Help|Documentation (F1) – This command displays this online documentation using your standard webbrowser. You have to be connected to the Internet to be able to receive this documentation.

Help|Check for update – Use this command to check if there is a newer version of FTPEditor available. Once an updated version is detected you will be prompted to download and install the update.

Help|Request feature / Report problem – Use this command to launch the FTPEditor Support-System. There you report problems you find with FTPEditor or request new features to be added.

Help|About – Use this command to display the version number of your copy of FTPEditor, the homepage URL and email address.

[ back to the top ]

FTP File list popup-menu

If you right click in the FTP file list a popup menu appears containing these options:

Open – see File|Open

Download – see File|Download

Refresh – Use this command to refresh the display of the current directory.

Delete – see FTP|Delete

Move – see FTP|Move

Rename – see FTP|Rename

Make Directory – see FTP|Make Directory

Change Directory – see FTP|Change Directory

Properties – see FTP|Properties

[ back to the top ]

4. SiteManager

The SiteManager stores information about FTP accounts. So you don’t have to enter the same information again and again.

When you use the SiteManager the first time, you may directly enter a new account. Fill out the fields with the following information (you may have to ask your website administrator for the details, if you don’t know or are not sure about them).

  • Name – enter a name for an account here (e.g. “My FTP account”)
  • Host – enter your FTP server name or its IP address here
  • User – enter the user name of your account (mark the anonymous box if you want to login as a guest user)
  • Password – enter the password of your account (mark “Save Password” if you want FTPEditor to save your password)
    ATTENTION: Saving the password on your PC, is not completely save.
  • Remote dir – enter the directory on your FTP server you would like to start in after connect (e.g. “/wwwroot”)
  • Local dir – enter the directory on your PC you would like to start in after connect (e.g. “c:\temp\”)
  • Create local backup (Pro version only) – when marked, this will create backups of all the edited files to the folder set in local dir.

Creating a new account:

The “New”-button will empty all fields and let you enter another account. Be sure to save an account (pressing the “Save”-button) before you create a new one.

Editing an account:

Select the account you want to edit from the account list. The fields are filled with the values of this account and you may edit them. But sure to save them when you are finished.

Deleting an account:

If want to delete an account, select it from the account list and press the “Delete”-button.

Connecting to an account:

Select the account you want to connect to from the account list. Then press the “Connect”-button. The SiteManager will close and FTPEditor connects to the selected account.

TIP !!!
Once you are connected to an account successfully this account will be put in the FTP server history of FTPEditor. Use this shortcut to connect to your account without even using the SiteManager.

[ back to the top ]

5. Editor Options

For each syntax highlighting module a large set of features can be set by using the Editor Properties dialog. Use the Tools|Editor Properties or the editor pop-up menu (right mouse key).

5.1 Options Tab

In the Options tab you may edit general editor properties.

Editor options
  • Highlight current line in editor – highlight the current line using a background color
  • Show line numbers- display line numbers before each line
  • Tabs to spaces – insert tab characters as whitespaces
  • Smart tabs – indent tab using previous line information
  • Trim trailing spaces – delete spaces at the end of the line when saving
  • Tab Width – size of tab characters
Editor font
Set font family and font size for the editor text.
5.2 Highlighting Tab

In the Highlighting Tab you may change colors and text attributes for all elements of the current syntax highlighting module. You change these settings for an element and see the results in the preview area. Once you are finished press the Ok-Button and the current settings will be applied to the editor.

5.3 Shortcut Tab

Adjust the keyboard shortcuts for editor commands.

[ back to the top ]

6. Options

The Options dialog consists of a tabbed dialog with the following pages:

General:

  • Put in tray when minimized: hides FTPEditor from the taskbar when it is minimized, but puts the FTPEditor icon into the tray icon.
  • Batch download: downloads all selected files to a local folder without displaying the save dialog for every file.
  • Show SiteManager at startup: displays the SiteManager dialog, when FTPEditor is started.
  • Allow multiple instances: Removes the limit to have only one FTPEditor main window.
  • Team development: Locks files being edited by FTPEditor users to protect another user to edit the same files, which could cause data loss. (Only works when all users use FTPEditor)
  • Show hidden files/folder in Explorer: toggles the display of hidden item in the Explorer
  • Binary files: Files with these extensions cannot be edited using FTPEditor (since they are in binary format) and FTPEditor will use binary file transfer to up-/download these files. If a file seems to be corrupted after tranfering it, you may have to add its file extension here.

FTP:

  • Port: Use this field to set the port number which FTPEditor uses to communicate with FTP servers. Port 21 is the standard port for the FTP protocol.
  • Idle Time: FTPEditor sends a “no operation” command to the FTP server if a connection has be idle for the amount of specified seconds. The commands does nothing but remain the connection to the FTP server.
  • TimeOut: FTPEditor abort transactions with the FTP server if it does not receive a feedback for the amount of seconds set in timeout.
  • Proxy Options: in this group you can specify proxy options and select if the should enabled by default
  • Proxy: Use this field to tell FTPEditor the name of the proxy server you wish to work with.
  • Proxy Port: Use this field to specify the port which the proxy server listens to for FTP transfers.
  • Username: If your proxy required authentication enter your proxy username here.
  • Password: If your proxy required authentication enter your proxy password here.

Advanced:

  • Update notification: FTPEditor checks for new versions when it is launched. This can be disabled here.
  • Delete server history: Removes all saved entries from the server field in the toolbar.

[ back to the top ]